Configurasi Cisco Router 2811 & Catalyst 2950 sebagai VLAN


Jaringan kerja yang luas dan user yang  banyak serta banyaknya  devices yang terkoneksi ke network, akan mengakibatkan tingginya lalu lintas data. Agar tidak terjadi collision domain dan broadcast pada suatu jaringan  kita harus mengatur agar network tetap berjalan baik. Netwok yang tidak di atur dengan baik akan banyak sekali masalah yang di timbulkan.

Berikut ini adalah basic routing dan configurasi  beberapa Cisco Router dan Switch Catalyst yang menghungkan gedung A dan gedung B agar bisa saling terkoneksi dalam suatu network. Di kesempatan ini saya tidak menjelaskan secara detail langkah demi langka, tetapi hanya fokus pada routing dan configurasi pada Switch.

Configrasi pada Router Gedung A

ROUTER-A#conf t
ROUTER-A(config)#interface fastethernet 0/0
ROUTER-A(config-if)#ip address 10.0.10.1 255.255.255.252
ROUTER-A(config-if)#no shutdown
ROUTER-A(config-if)#exit
ROUTER-A(config)#
Enter configuration commands, one per line.  End with CNTL/Z.
ROUTER-A(config)#interface fastethernet 0/1.1
ROUTER-A(config-subif)#encapsulation dot1Q  10
ROUTER-A(config-subif)#ip address 172.16.10.254 255.255.255.0
Enter configuration commands, one per line.  End with CNTL/Z.
ROUTER-A(config)#interface fastethernet 0/1.2
ROUTER-A(config-subif)#encapsulation dot1Q 20
ROUTER-A(config-subif)#ip address 172.16.20.254 255.255.255.0
ROUTER-A(config-subif)#exit
ROUTER-A(config)#
ROUTER-A(config)#interface fastethernet 0/1.3
ROUTER-A(config-subif)#encapsulation dot1Q 30
ROUTER-A(config-subif)#ip address 172.16.30.254 255.255.255.0
ROUTER-A(config-subif)#exit
ROUTER-A(config)#

Configurasi Switch Pada Gedung A

Switch-A>en
Switch-A#vlan database
Switch-A(vlan)#vlan 10 name finance
VLAN 10 added:
    Name: finance
Switch-A(vlan)#vlan 20 name accounting
VLAN 20 added:
    Name: accounting
Switch-A(vlan)#vlan 30 name marketing
VLAN 30 added:
    Name: marketing
Switch-A(vlan)#
Switch-A#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch-A(config)#interface fastEthernet 0/1
Switch-A(config-if)#switchport mode trunk
Switch-A(config-if)#exit
Switch-A(config)# interface fastEthernet 0/2
Switch-A(config-if)#switchport access vlan 10
Switch-A(config-if)#switchport mode access
Switch-A(config-if)#exit
Switch-A(config)# interface fastEthernet 0/3
Switch-A(config-if)#switchport access vlan 20
Switch-A(config-if)#switchport mode access
Switch-A(config-if)#exit
Switch-A(config)# interface fastEthernet 0/4
Switch-A(config-if)#switchport access vlan 30
Switch-A(config-if)#switchport mode access

Configrasi pada Router Gedung B

ROUTER-B#conf t
ROUTER-B(config)#interface fastethernet 0/0
ROUTER-B(config-if)#ip address 10.0.10.2 255.255.255.252
ROUTER-B(config-if)#no shutdown
ROUTER-B(config-if)#exit
ROUTER-B(config)#
ROUTER-B(config)#interface fastEthernet 0/1.1
ROUTER-B(config-subif)#encapsulation dot1Q 10
ROUTER-B(config-subif)#ip address 172.19.10.254 255.255.255.0
ROUTER-B(config-subif)#no shutdown 
ROUTER-B(config-subif)#
ROUTER-B#conf t
ROUTER-B(config)#interface fastEthernet 0/1.2
ROUTER-B(config-subif)#encapsulation dot1Q 20
ROUTER-B(config-subif)#ip address 172.19.20.254 255.255.255.0
ROUTER-B(config-subif)#no shutdown 
ROUTER-B(config-subif)#
ROUTER-B#conf t
ROUTER-B(config)#interface fastEthernet 0/1.3
ROUTER-B(config-subif)#encapsulation dot1Q 30
ROUTER-B(config-subif)#ip address 172.19.30.254 255.255.255.0
ROUTER-B(config-subif)#no shutdown 
ROUTER-B(config-subif)#
ROUTER-B#

Configurasi Switch Catalyst 2950 Gedung B

Switch-B#vlan database
Switch-B(vlan)#vlan 10 name lantai-1
VLAN 10 added:
    Name: lantai-1
Switch-B(vlan)#vlan 20 name lantai-2
VLAN 20 added:
    Name: lantai-2
Switch-B(vlan)#vlan 30 name lantai-3
VLAN 30 added:
    Name: lantai-3
Switch-B(vlan)#vlan 40 name lantai-4
VLAN 40 added:
    Name: lantai-4
Switch-B(vlan)#
Switch-B(config)#interface fastEthernet 0/1
Switch-B(config-if)#switchport mode trunk
Switch-B(config-if)#exit
Switch-B(config)#
Switch-B(config)#interface fastEthernet 0/2
Switch-B(config-if)#switchport access vlan 10
Switch-B(config-if)#switchport mode access
Switch-B(config-if)#exit
Switch-B(config)#
Switch-B(config)#interface fastEthernet 0/3
Switch-B(config-if)#switchport access vlan 20
Switch-B(config-if)#switchport mode access
Switch-B(config-if)#exit
Switch-B(config)#
Switch-B(config)#interface fastEthernet 0/4
Switch-B(config-if)#switchport access vlan 30
Switch-B(config-if)#switchport mode access
Switch-B(config-if)#exit
Switch-B(config)#

Selamat mencoba

Mesdsa

One thought on “Configurasi Cisco Router 2811 & Catalyst 2950 sebagai VLAN

  1. bisa dijelasin lebih detail gan? ane udah ikutin semua config buat router sama switchnya tp kok tetep gabisa kirim pesan ya dalam satu vlan maupun antar vlan

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s